Amazon Linux AMIでyum updateができなくなった時の対処法

Amazon EC2のインスタンス、Amazon Linux AMIでyum updateしようと思ったら、エラーがでました。

Loaded plugins: priorities, update-motd, upgrade-helper
Config error: Command “updateinfo” already defined

どうもプラグインに問題があるようなので、プラグインを読み込まないように設定。

vi /etc/yum.conf

plugins=1 → plugins=0

これでyum updateすると無事に更新できました。

ちなみにアップデート後、1に戻したら今度は正常に動いているようです。

「Amazon Linux AMIでyum updateができなくなった時の対処法」への1件のフィードバック

コメントを残す